Getting message "Could not parse the template" after upgrade

Richard Carter ricky28269 at
Wed Aug 17 16:23:49 BST 2011

Hi xmobar people!

I updated a computer this morning which doesn't often get updates, so it
just updated to xmobar 0.13-2 from the Arch community repository. However
now when I run xmonad, I get a bar which looks like this:

Could not parse the template }{ 93 | Wed Aug 17 2011 11:21:45AM

where }{ is the alignSep, working as it should (the text to the left of it
is left-aligned, and the battery and date are in the top right).

So clearly it's having an issue parsing my template. Which I didn't touch
before or after the upgrade. I haven't touched it in months. Here is the
contents of my xmobarrc file:

{ bgColor = "black"
, fgColor = "grey"
, position = Top
, lowerOnStart = True
, commands =
[ Run Date "%a %b %_d %Y %I:%M:%S%p" "date" 10
, Run Com "uname" ["-s","-r"] "" 36000
, Run BatteryP ["BAT0"] ["-t","<left>","--","-O","[on] ","-o",""] 50
, alignSep = "}{"
, sepChar = "%"
, template = "mod-p, mod-shift-enter, mod-shift-q }{ %battery% | %date%"

Any idea what could be breaking? I've tried removing the hyphens in the
text, surrounding it with <fc=#FFFFFF> </fc>, and removing the alignSep.
Google is showing nothing, except a person who removed their alignSep to
success - and I'd rather not do that, because I want things to be in the
top-left and top-right.

Thanks for any help!!

P.S. I signed up to the mailing list but not yet sure if I am actually
receiving the messages, so please reply directly to me (CC the mailing list
if you want).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Xmobar mailing list