Macport installation failed

interferenz x42 at
Thu May 14 15:44:37 EDT 2009


Ok, all done, with the modified cabal file I coud compile Leksah.
However, if I start the binary the following error is reported:

PowerG5$ ./leksah
start gui called
ide: internal IDE error: Cannot initialize GUI.

No further messages nor console messages. Seems there are some  
unresolved Problems.


Am 14.05.2009 um 16:35 schrieb Hamish Mackenzie:

> I have not tried leksah on OSX with 6.10.2 yet.  I am afraid you may
> experience problems with gtk2hs 0.10.0 (still the default for
> MacPorts).  So it might be a good idea to upgrade to gtk2hs 0.10.1
> (which I understand has some important changes to support 6.10.2).  I
> have attached an updated Portfile for gtk2hs 0.10.1
> Replace the file
>    /opt/local/var/macports/sources/ 
> devel/gtk2hs/Portfile
> with the one attached then run
>    sudo port uninstall gtk2hs
>    sudo port -k install gtk2hs
> Next thing is to avoid that Cabal error.  From http:// 
> ...
>    "Currently you have to change Cabal == to Cabal >=
> in the leksah.cabal file by hand. So you have to install leksah with
> runhaskell Setup configure (--user) ... We will fix this with the next
> release."
> This means you will need to download and extract the leksah.tar.gz
> file or run "darcs get"
> Edit leksah.cabal as described (I think the darcs version is actually
> fixed already)
> Then in the same directory as the leksah.cabal file run
>    cabal install
> I will probably try this with GHC 6.10.2 or maybe .3 this weekend on
> my intel Mac.  Please let us know how you get on on the PPC as I don't
> know if anyone has tried that yet.
> 2009/5/14 interferenz <x42 at>:
>> Hello,
>> I have tried to install Leksah via MacPorts on OSX 10.5.6 PPC, but  
>> the
>> following
>> error occurred:
>> cabal install leksah
>> Resolving dependencies...
>> cabal: dependencies conflict: ghc-6.10.2 requires Cabal ==
>> however
>> Cabal- was excluded because Cabal- was selected instead
>> Cabal- was excluded because leksah- requires Cabal  
>> ==1.6.0
>> I have installed ghc 6.10.2.with sudo port -k install ghc gtk2hs hs-
>> cabal, ghc 6.10.1 was already installed.
>> Obviously there is a version conflict, how can I solve it?
>> I am not a dedicated unix dude by the way...
>> greetings
>> Volker
>> _______________________________________________
>> Leksah mailing list
>> Leksah at
> <Portfile>

More information about the Leksah mailing list