Release 0.4.3

Jürgen Nicklisch-Franken jnf at
Wed Mar 18 01:20:22 EDT 2009

Hallo Daniel,
sorry not to tell. I succeeded by changing the dependency manually to  
Cabal- When I published the new version I changed the dependency
to >= Cabal-1.6.0, but it gave an error message like leksah needs
Cabal- and ghc wants Cabal- So I didn't change it for the
moment. Cabal is not so easy to understand for me sometimes.

So please edit leksah.cabal manually and do a runhaskell Setup
configure, build, install.

Am Mittwoch, den 18.03.2009, 06:10 +0100 schrieb Daniel Schüssler:
> Hi,
> On Tuesday 17 March 2009 21:25:31 Jürgen Nicklisch-Franken wrote:
> > I've tried to install leksah with the new release candidate of ghc.
> >
> >tml (On my Ubuntu I had to add a symlink to editline2, or something like
> > this.) In the end leksah crashed every some seconds with a foreign pointer
> > finalizer error. If something can try this on a different
> > machine it would be great help.
> I can't even get that far:
> $ cabal install leksah
> Resolving dependencies...
> cabal: dependencies conflict: ghc- requires Cabal ==
> however
> Cabal- was excluded because Cabal- was selected instead
> Cabal- was excluded because leksah-0.4.3 requires Cabal ==
> Greetings,
> Daniel
> _______________________________________________
> Leksah mailing list
> Leksah at

More information about the Leksah mailing list