compilation error; Not in scope: `sourceLanguageManagerGuessLanguage'

H-----t K---------h h-----tk--------h at
Sun Mar 8 14:41:38 EDT 2009

Dear reader,

I am trying to install leksah, but this fails. I have ran ./Setup.hs
configure in the leksah tar.gz package which succeeded. Unfortunately
step 24 of the build failed;

localhost leksah-0.4.1 # ./Setup.lhs configure
Configuring leksah-0.4.1...
localhost leksah-0.4.1 # ./Setup.lhs build
Preprocessing executables for leksah-0.4.1...
Building leksah-0.4.1...
[24 of 46] Compiling IDE.Completion   ( src/IDE/Completion.hs,
dist/build/leksah/leksah-tmp/IDE/Completion.o )

    Not in scope: `sourceLanguageManagerGuessLanguage'
    localhost leksah-0.4.1 #
localhost leksah-0.4.1 #

As I googled the issue I came to this page on

I read:

    * When you get the following error:

|src/IDE/Completion.hs:87:26: |

   Not in scope: `sourceLanguageManagerGuessLanguage'

you have to install gtksourceview2 in a version > 2.4.0

So I want googling on gtksourceview2, but only found gtksourceview which
currenty is at version 2.4.1. So I though, maybe this one is the same
and the 2 doesn't mean anything. I installed it by compiling it by hand,
since my package system (gentoo; portage) only had version
2.2.something. All went fine, but still I can;t compile leksah, since it
keeps exiting on the same error.

I tried to find gtksourceview2, but could only find gtksourceview. I
also couldn;t determine the difference.

Could someone help me please?

Your Sincerely,

More information about the Leksah mailing list