New release of Leksah

João Paulo Pizani Flor joaopizani at
Sun Jul 26 09:21:08 EDT 2009

I confirm the same problem here. I wasn't being able to "./Setup.lhs
configure" Leksah because of the regex-base== dependency. Then I
changed it manually in the leksah.cabal file to regex-base>= and it
compiled and worked just fine...

I am running Leksah on Ubuntu 9.04 and the IDE is great! Thank you! Leksah
will surely help bring people to the Haskell land :)

I'm currently trying to assemble a virtual appliance with the Haskell
Platform and Leksah, ready to run and have fun, so that the installation
mess is left out of the scene when someone just want to have a "taste" of
the language.


João Paulo Pizani Flor
Federal University of Santa Catarina - Brazil

2009/7/26 Maciej Noszczyński <maciej.noszczynski at>
> Works as advertised.
> BTW. It might be useful to change in leksah.cabal:
> regex-base == to regex-base >=
> as this constraint causes dependency resolution errors (at least on my
> system).
> _______________________________________________
> Leksah mailing list
> Leksah at
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Leksah mailing list