crahsing. can I help ?

Jürgen Nicklisch-Franken jnf at
Sat Apr 11 05:12:14 EDT 2009

Hello Luc,
I've a machine were the same problem occured under Ubuntu. I reinstalled
the newest ghc from source, compiled the newest gtk2hs from darcs, and
the problem seems to have vanished. 

So I really can't say what is happening, but it seems to be a subtile
problem with installation. If you have some time and try this as well?
On the Wiki is a description of the installation procedure for Ubuntu,
which describes pretty exactly what I did. This compiling takes some

You have to take care, that you don't execute an old installed version
of Leksah, which is what I did first.

Happy Easter

Am Donnerstag, den 09.04.2009, 18:45 +0200 schrieb luc.taesch at
> i added my config details in the ticket 61, guys.
> let me know if I can bring more details.
> thanks for the help.
> Luc
> On Thu, Apr 9, 2009 at 11:53 AM, Jutaro <jutaro at> wrote:
>         Luc,
>         this seems to be a "difficult" error, I've seen it before on
>         one of my
>         machines. I add it to our bug tracker. It may depend on the
>         graphic
>         card. So can you provide us with information about your
>         graphic card
>         driver and OS.
>         Thanks
>         Juergen
>         Am Sonntag, den 05.04.2009, 18:56 +0200 schrieb
>         luc.taesch at
>         > leksah: /build/buildd/cairo-1.8.0/src/cairo-pattern.c:2095:
>         > _cairo_pattern_get_extents: Assertion `status ==
>         > failed.

More information about the Leksah mailing list