trouble with gtksourceview2
DealeyLama at gmx.de
Fri Apr 10 15:31:54 EDT 2009
Thanks for the suggestion...but it - I don't know because of waht - I'm
still not able to install leksah.
I've changed leksah's cabal-file to as suggested but a configure results
in the following warnings:
Warning: This package indirectly depends on multiple versions of the same
package. This is highly likely to cause a compile failure.
package ghc-6.10.2 requires Cabal-188.8.131.52
package leksah-0.4.4.1 requires Cabal-1.7.0
The build abborts wit this error:
Preprocessing executables for leksah-0.4.4.1...
[10 of 46] Compiling IDE.Core.Types ( src/IDE/Core/Types.hs,
[11 of 46] Compiling IDE.Core.State ( src/IDE/Core/State.hs,
[12 of 46] Compiling IDE.FileUtils ( src/IDE/FileUtils.hs,
[13 of 46] Compiling IDE.Metainfo.GHCUtils (
Couldn't match expected type
against inferred type
Inferred type: [PackageConfig]
In the second argument of `map', namely `knownPackages'
In the expression: map IPI.package knownPackages
I'm puzzled... :(
Is there a step-by-step explanation how to install leksah anywhere?
Something the tells me about the dependencies and in which order wich
packages have to be installed in which version?
Thank you in advance.
Jürgen Nicklisch-Franken schrieb:
> Hello Alexander,
> this should be easy, as leksah doesn't really care about the Cabal
> version. The problem is only how to tell this to Cabal.
> (See this thread:
> and Issue 58 in the tracker.
> The solution is to enter the version of Cabal in leksah.cabal that ghc
> Then install with runghc configure/build/install.
> Am Dienstag, den 07.04.2009, 23:37 +0200 schrieb Alexander Schell:
>> Thank you for the swift reply.
>> Now I'm running into another problem:
>> Configuring leksah-0.4.4.1...
>> Warning: This package indirectly depends on multiple versions of the same
>> package. This is highly likely to cause a compile failure.
>> package leksah-0.4.4.1 requires Cabal-184.108.40.206
>> package ghc-6.10.2 requires Cabal-220.127.116.11
>> The build fails as expected:
>> Preprocessing executables for leksah-0.4.4.1...
>> Building leksah-0.4.4.1...
>> [13 of 46] Compiling IDE.Metainfo.GHCUtils (
>> dist/build/leksah/leksah-tmp/IDE/Metainfo/GHCUtils.o )
>> Couldn't match expected type
>> against inferred type
>> Expected type:
>> Inferred type: [PackageConfig]
>> In the second argument of `map', namely `knownPackages'
>> In the expression: map IPI.package knownPackages
>> Same with 'cabal install leksah':
>> Resolving dependencies...
>> cabal: dependencies conflict: ghc-6.10.2 requires Cabal ==18.104.22.168 however
>> Cabal-22.214.171.124 was excluded because Cabal-126.96.36.199 was selected instead
>> Cabal-188.8.131.52 was excluded because leksah-0.4.4.1 requires Cabal ==184.108.40.206
>> I don't know what to do about this; it seems that this problem can not
>> be solved this easy.
>> Should I try to get a ghc version which depends on the same Cabal version?
>> Thank you in advance.
>> Alexander Schell
>> at the server schrieb:
>>>> At 07.04.2009 22:38, Alexander Schell wrote:
>>>>>> I'm trying to install leksah but it keeps telling me that the
>>>>>> gtksourceview2-dependence is not fulfilled although I've installed
>>>>>> Configuring leksah-0.4.4.1...
>>>>>> Setup.lhs: At least the following dependencies are missing:
>>>> You have to install the development conterpart od gtksourceview2
>>>> package prior to building gtk2hs.
>> Leksah mailing list
>> Leksah at projects.haskell.org
More information about the Leksah