[haskell-platform] #182: Haskell Platform will not install on current Macintosh

haskell-platform haskell-platform at projects.haskell.org
Sun Nov 6 21:45:10 GMT 2011

#182: Haskell Platform will not install on current Macintosh
 Reporter:  fwburton       |        Owner:  MtnViewMark
     Type:  defect         |       Status:  new        
 Priority:  major          |    Milestone:  2011.x.0.0 
Component:  OSX installer  |   Resolution:             
 Keywords:  installation   |  
Changes (by srmurthy):

  * keywords:  => installation
  * milestone:  => 2011.x.0.0


 I am completely new to Haskell, but I am also having problems in
 installing the latest Haskell version 2011.2.0.1 for Mac OS X 10.6 (Snow
 Leopard).  I've downloaded the package file, and tried to run it, only to
 get an error message after the password verification screen for the
 install.  The message is "The Installation failed.   The installation
 could not install the software.  The installer could not install the
 software because there was no software found to install."  The related
 console message is:

 "06/11/2011 21:41:43    Installer[2418] Package
 /Users/sandeepmurthy/Downloads/Haskell Platform 2011.2.0.1-i386.pkg uses a
 deprecated pre-10.2 format (or uses a newer format but is invalid)."

 I thought the current Haskell for Mac package was the right one for Snow

 Any help would be appreciated.  Sandeep.

 Replying to [ticket:182 fwburton]:
 > I am running MacOS 10.7 (Lion) with Xcode 4.1 9 (the most recent
 versions in both cases).
 > I cannot install the current 32 bit version of the Haskell Platform.  I
 am attaching a screen shot of the error that the Haskell Installer
 returns.  [[Image(/Users/burton/Desktop/Screen Shot 2011-07-23 at 7.52.53

Ticket URL: <http://trac.haskell.org/haskell-platform/ticket/182#comment:8>
haskell-platform <http://trac.haskell.org/haskell-platform>
The Haskell Platform: a comprehensive and robust collection of Haskell libraries

More information about the Haskell-platform mailing list