[haskell-platform] #137: Linking error when using Text.Regex.Posix

haskell-platform haskell-platform at projects.haskell.org
Fri Sep 24 18:02:47 EDT 2010

#137: Linking error when using Text.Regex.Posix
 Reporter:  axqd               |        Owner:  refold    
     Type:  defect             |       Status:  assigned  
 Priority:  major              |    Milestone:  2010.2.0.0
Component:  Windows installer  |   Resolution:            
 Keywords:                     |  
Comment (by raould):

 cabal "solution" does not work for me.

 to wit:
 * i'm using winxp, just installed Haskell Platform today (2010.2.0.0).
 * trying to use the Example from Test.Framework is how i hit this.
 * using winghci.
 * get a link error: Loading package regex-posix-0.94.2 ... linking ...
 ghc: unable to load package `regex-posix-0.94.2'.
 * tried cabal install, it installed 0.94.4.
 * restarting winghci and trying again gives me the same error. i assume it
 is because the version numbers are not the same.
 * did ghc-pkg unregister regex-posix-0.94.4, then cabal install regex-
 posix-0.94-2 --reinstall, but that failed due to missing regex.h (of

 so i am guessing that the Haskell Platform for Windows has some
 configuration file that assumes/requires exactly 0.94.2, and won't notice
 0.94.4. (like, when i do ghc-pkg list regex-posix, it lists C:/Program
 Files/Haskell Platform/2010.2.0.0\lib\package.conf.d: regex-posix-0.94.2.)


Ticket URL: <http://trac.haskell.org/haskell-platform/ticket/137#comment:5>
haskell-platform <http://trac.haskell.org/haskell-platform>
The Haskell Platform: a comprehensive and robust collection of Haskell libraries

More information about the Haskell-platform mailing list