Status update: HP 2011.x and GHC 7

Don Stewart dons at
Sat Nov 6 12:22:07 EDT 2010

I have built a very early candidate for the Haskell Platform 2011 set,
ignoring any active proposals, using GHC 7.

Issues that were raised:

= Haskell Platform packages that have broken the HP policy, by adding new 
  dependencies that are not part of the Haskell Platform set:

        * cgi (known issue)
             + adds MonadCatchIO-mtl (12 packages use it) dependency.
             + last compliant version 3001.1.7.4
        * GLUT (known issue)
             + adds StateVar -any (9 packages use it), Tensor -any (4 packages use it)
             + last compliant version
        * OpenGL (known issue)
             + adds  OpenGLRaw >= (6 users)
                     GLURaw >=, (1 user)
                     StateVar -any, (9 users)
                     ObjectName -any, (2 users)
                     Tensor -any (4 users)
             + last compliant version

= Haskell Platform packages that will break with GHC 7, because base 3 has gone away:

        * haskell src-
                ++ libraries will have to fix this
= Other inconsistencies with currently released packages:

        * time was excluded because cabal-install-0.8.2 requires time ==1.1.*
                ++ assuming new cabal-install release soon?
        * haddock 0.8.1 is out, but ghc 7 RC is shipping with haddock 0.8.0

        * stm uses throwSTM, which wasn't in the release candidate.

More information about the Haskell-platform mailing list