ghc-asm problem in OS-X 2010.2.0.0 when compiling happstack-util

Doug Burke doug_j_burke at
Fri Jul 23 17:08:34 EDT 2010

I installed the 2010.2.0.0 OS-X package today which was very easy. So far so good except for the following problem when trying to install happstack-util

% cabal install happstack-util
... lots of stuff deleted ...

    Warning: A do-notation statement discarded a result of type ExitCode.
             Suppress this warning by saying "_ <- waitForProcess ph",
             or by using the flag -fno-warn-unused-do-bind
[13 of 19] Compiling Happstack.Crypto.MD5 ( src/Happstack/Crypto/MD5.hs, dist/build/Happstack/Crypto/MD5.o )
ghc: could not execute: /Library/Frameworks/GHC.framework/Versions/612/usr/lib/ghc-6.12.3/ghc-asm
cabal: Error: some packages failed to install:
happstack-util- failed during the building phase. The exception was:
ExitFailure 1

The ghc-asm executable exists - 

% ls -l /Library/Frameworks/GHC.framework/Versions/612/usr/lib/ghc-6.12.3/ghc-asm
-rwxrwxr-x  1 root  admin  74344 Jun 11 11:42 /Library/Frameworks/GHC.framework/Versions/612/usr/lib/ghc-6.12.3/ghc-asm

- but the problem is that it uses an invalid perl location - namely /opt/local/bin as shown below

% head -1 /Library/Frameworks/GHC.framework/Versions/612/usr/lib/ghc-6.12.3/ghc-asm

If I manually change it to the location of perl

% which perl
% head -1 /Library/Frameworks/GHC.framework/Versions/612/usr/lib/ghc-6.12.3/ghc-asm

then 'cabal install happstack-util' works.

Let me know if you need any more info,


More information about the Haskell-platform mailing list