[haskell-platform] #100: <Problem> installed on osx 10.6 ghci not working

haskell-platform haskell-platform at projects.haskell.org
Mon Nov 30 03:13:21 EST 2009

#100: <Problem> installed on osx 10.6 ghci not working
 Reporter:  johnstjohn  |        Owner:  dons      
     Type:  defect      |       Status:  closed    
 Priority:  major       |    Milestone:            
Component:  GHC         |   Resolution:  worksforme
 Keywords:              |  
Changes (by johnstjohn):

  * status:  new => closed
  * resolution:  => worksforme


 The fix to this problem with snow leopard is to do the following
 1. sudo mv /usr/local/lib/libiconv.2.dylib
 2. ln -s /usr/lib/libiconv.2.dylib /usr/local/lib/libiconv.2.dylib

 That's it! I guessed this was the problem when I noticed the file size of
 the 'libiconv.2.dylib' that is linked to in /usr/local/lib is smaller than
 the one located in /usr/lib. Kind of a hack and I am hoping this doesn't
 break anything else in my system. If it does I can just reestablish

Ticket URL: <http://trac.haskell.org/haskell-platform/ticket/100#comment:1>
haskell-platform <http://trac.haskell.org/haskell-platform>
The Haskell Platform: a comprehensive and robust collection of Haskell libraries

More information about the Haskell-platform mailing list