[haskell-platform] #26: Source tarball needs INSTALL file

haskell-platform haskell-platform at projects.haskell.org
Wed May 6 05:00:21 EDT 2009

#26: Source tarball needs INSTALL file
 Reporter:  tibbe                   |       Owner:  duncan
     Type:  defect                  |      Status:  new   
 Priority:  major                   |   Milestone:        
Component:  Generic source tarball  |    Keywords:        
 While trying to install from the source tarball I got this error:

 $ ./configure --prefix=$HOME
 checking GL/glu.h usability... no
 checking GL/glu.h presence... no
 checking for GL/glu.h... no
 configure: error: The OpenGL C library is required
 make: *** [config.status] Error 1

 Turns out that it's non-trivial to figure out which package provides
 OpenGL on Ubuntu. Installing libgl1-mesa-dev which provides the virtual
 package libgl-dev didn't work.

 An INSTALL file that lists the additional packages needed on different
 platforms would be nice.

Ticket URL: <http://trac.haskell.org/haskell-platform/ticket/26>
haskell-platform <http://trac.haskell.org/haskell-platform>
The Haskell Platform: a comprehensive and robust collection of Haskell libraries

More information about the Haskell-platform mailing list