[haskell-llvm] MathExtras.h: error: there are no arguments to ‘INT64_C’ that depend on a template parameter, so a declaration of ‘INT64_C’ must be available

Ilias Tsitsimpis iliastsi at hotmail.com
Mon Apr 30 10:42:24 BST 2012

On 04/30/2012 01:52 AM, Henning Thielemann wrote:
> I have now installed LLVM-3.0 and try to compile llvm-base from git
> repository.

Hello Henning,

 llvm-base is not compatible with LLVM-3.0 yet. There are some patches
that fix this problem (you can find them in github pull request pages
[1]) but nothing official yet. On the other hand LLVM-2.9 works fine so
you can try this one.


[1] https://github.com/bos/llvm/pulls

More information about the Haskell-llvm mailing list