[haskell-llvm] [Haskell-cafe] Hackage have ghc 7.0 false positives builds

Henning Thielemann thunderbird at henning-thielemann.de
Wed Dec 8 08:45:11 EST 2010

Maciej Piechotka wrote:
> On Tue, 2010-12-07 at 21:42 +0100, Henning Thielemann wrote:
>> This looks like an incompatibility with respect to Cabal, not with respect 
>> to the 'llvm' modules and GHC-7.
> Yes. But since ghc-7 contains cabal 1.10 and you cannot compile cabal
> 1.8 with ghc-7 (I've tried) I believe that it should be marked as
> non-buildable on ghc-7 on hackage. I don't recall mentioning any
> problems with llvm (as C++ library).

If Hackage succeeded to build llvm it would be great to find out, how it 
achieved that in order to reproduce it on a private machine.

More information about the Haskell-llvm mailing list