[haskeline] #81: haskeline assumes all characters have width = 1

haskeline haskeline at projects.haskell.org
Thu Sep 17 03:18:39 EDT 2009

#81: haskeline assumes all characters have width = 1
Reporter:  guest   |        Owner:       
    Type:  defect  |       Status:  new  
Priority:  major   |    Milestone:  0.6.*
 Version:  0.6     |   Resolution:       
Keywords:          |  
Changes (by judah):

  * priority:  minor => major
  * milestone:  0.6.2 => 0.6.*


 I got a report from Ahn Ki Yung that Haskeline doesn't handle double-wide
 characters.  With his help, I was able to reproduce the issue:

  I ran the example program in the Haddock documentation, and typed
  three Korean characters


  I first typed in my name above and pressed return, and as you see the
  three characters got into the buffer. Then, I type my name and tried
  to delete them with three backspace and here's what happens:


  kyagrd at kyavaio:~/tmp$ ghc-pkg list|grep haskeline
     haskeline-, haskell-src-, (haskell-src-exts-1.0.1),
     hashed-storage-0.3.6, haskeline-0.6.2, haskell-src-exts-0.3.12,
  kyagrd at kyavaio:~/tmp$ runghc haskelinetest.hs
  % 안기영
  Input was: 안기영
  % 안기
  Input was:

  I strongly suspect that Chinese and Japanese input will have the same
  problem as well.

Ticket URL: <http://trac.haskell.org/haskeline/ticket/81#comment:5>
haskeline <http://example.org/>
My example project

More information about the Haskeline mailing list