[haskell-gnuplot] Please help with xtic on histogram!

Dmitri O.Kondratiev dokondr at gmail.com
Sun Jun 12 19:00:04 BST 2011

On Sun, Jun 12, 2011 at 9:42 PM, Henning Thielemann <
lemming at henning-thielemann.de> wrote:

> On Sun, 12 Jun 2011, Dmitri O.Kondratiev wrote:
>  Hello,
>> I am trying to read xtic labels from data file for histogram chart.
>> On X axis I need labels, from the last, 5-th column of my data file
>> (see bellow).
>> These labels have the form '[x1,x2..xN] such as [1,2,3], etc.
>> I am trying to use something like:
>> plot "t1dat.txt" u 2:xtic(5) t "Best Fit", "" u 3 t "In Class", "" u 4 t
>> "Other"
>> which does not show the labels.
> Are you sure, that gnuplot can handle the hyphens? Maybe gnuplot expects
> quotation marks for the labels in the 5th column.
> Anyway, if you use my gnuplot package, then the xtics are set via the 'set
> xtics' command. Please see the Demo.hs file for how it works.

As I understand hyphens are used to tell gnuplot that at the given (column,
row)  there is "no value" in histogram data table.
As for labels, gnuplot in my case draws just one for the first column. I
attach the chart that I get.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://projects.haskell.org/pipermail/gnuplot/attachments/20110612/fe3e4365/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen shot 2011-06-12 at 21.54.54.png
Type: image/png
Size: 29355 bytes
Desc: not available
URL: <http://projects.haskell.org/pipermail/gnuplot/attachments/20110612/fe3e4365/attachment-0001.png>

More information about the Gnuplot mailing list